Enterprise & Devops Software Integration Tool

Integrations with SwiftSync

SwiftSync* is an integration bus platform that provides integration for agile application and software development organizations that want to improve their development efficiency, increase organizational visibility, manage regulatory compliance, improve time-to-market, and more. SwiftSync supports over 60 enterprise-class integrations with popular tools such as TFS, JIRA, CA Agile Central and many others including those from HP, IBM, Accept, Serena, and more.

Extensive Integrations for Real-World Agile Solutions

SwiftSync Integration

SwiftSync has been architected, designed and built to enable multi-directional synchronization across your existing development environment, and in doing so, delivers seamless collaboration across your product development organization. Besides that, it provides full transaction history, audit trailing and recovery capability in case of any synchronization failures.

Using SwiftSync it is possible to visualize work across the organization, through your ecosystem of tools

SwiftSync supports integration with the following systems:

System Version Supported
Accept360 2018
Accompa* Latest Version
AccuRev SCM 6.2
AccuWork 6.2
Agilefant* 2.0.3
Blueprint 5.4, 5.5, 6.0, 6.1, 6.2, 6.3, 6.4, 7.0, 7.1, 7.2, 7.3
Bugzilla 3.6 and above, Tested on (3.6.3, 4.0.x, 5.0.2)
Caliber RM 11.3
Chiliproject* 3.1.0, 3.8.0
CVS* 1.11.22, 1.12
Enterprise Architect 10, 11
FogBugz 8.8.*, 8.9.*, 8.9.110.0H, 8.9.122.0H
Git 1.7.6, 1.8.3
HP ALM/HP QC 10.0, 11.0 (Patch 8 i.e. HP ALM 11.00 Service Pack 3 and later), 11.5, 11.5x, 12.0, 12.2, 12.5, 12.52, 12.53
HP Codar 1.0.0 (Windows)
IBM Rational DoorsNG 6.0.2
IBM Rational Clear Case 8.x
IBM Rational Clear Quest 7.1.2, 8.x
IBM Rational DOORS 9.1, 9.2, 9.3, 9.4, 9.5, 9.6
IBM Rational RequisitePro 7.0.1 and Above, Tested on (7.0.1, 7.1.2)
IBM Rational Team Concert 3.x, 4.x, 5.x, 6.0, 6.0.1
Jenkins Tested On 1.617 , 2.7.1 (1.652 Jenkins Version is not supported)
Jira 4.0 and Above (except 4.4), Sprint Entity is supported for Agile version 6.7.7 and above
Jira Agile Plugin 6.1.6 and above
Jira Zephyr Plugin 3.2
Mercurial 2.0-2.0.1, 2.6.1, 2.6.2
Mingle 12_2 to 14_1
MS Dynamics 8.0 and above
Perforce 2009.2, 2013.1, 2015
PTC Integrity 2009 and 10.x, Tested on: 2009 SP 6, 10.7
QASymphony qTest 7.10.0
CA Agile Central (RALLY) Version: All, API Version: v2.0
Redmine 2.0.1 and above
Remedy 6.3, 8.0, 8.1
Salesforce

All (as well as SaaS instance)

Tested on: API version v34.0

Serena Business Manager Serena Business Manager 2009 R3, R4, 10.1.2.1, 11.0
ServiceNow glide-fuji-12-23-2014__patch3-04-07-2015, Geneva Patch 7, Helsinki, Istanbul
Subversion 1.5 and Above Tested on (1.6.3, 1.6.17, 1.7.9)
SmartBear ALM/QA Complete 9.7.x, 9.8.x, 9.9.x, 10.x, 11.0
Selenium All
SwiftEnterprise 1.3.6, 1.4.18
SwiftKanban 3.5 to 4.4
TestTrack 2013, 2015, 2016
Team Foundation Server ALM 2010, 2012, 2013, 2015 (up to Update 3)
Meta entities such as Area Path, Iteration, Group, Team and User are not supported for version 2010
Team Foundation Server Version Control 2010, 2012, 2013, 2015 (up to Update 3)
Trac 0.12.0, 0.11.5, 1.0
VersionOne From 10.x upto 16.x
Visual Studio Online All
Visual Studio Online Version Control All
Visure 4.5, 4.6, 4.8
Zendesk All
Release Manager 2013
VManager 14.2
ALM Octane 12.55.3.112

Webservice APIs
For more details, please refer the knowledge base. If you don’t see your development system, please contact us at [email protected] and we’ll check if we can add it!

*Powered by OpsHub

SwiftSync Integration Platform

Integrate your Delivery Lifecycle! Build a DevOps Culture with Lean/ Agile ALM!

¡Inscríbase para una DEMO personalizada!